View Full Version : OpenGL 3 drawing not working

04-16-2011, 06:52 PM
I'm trying to draw a some objects the OpenGL 3 way, and nothing shows. I know my laptop supports OpenGL 3, it has a Nvidia 9400M G GPU. I have tried drawing with my own code, using various resources on Google, and I have tried using the project file from NeHe, http://nehe.gamedev.net/wiki/NewLesson1.ashx

I can get a window up, that runs fine, doesn't freeze. But I just see a black screen.

Does anyone know what could cause this?

04-17-2011, 12:56 AM
There's a lot of possible causes. I would recommend you to check for any errors with glGetError(). If there are any, try to pinpoint exactly where they occur.

04-17-2011, 04:59 AM
Try doing the most basic of things - set the clearcolor to red and just clear the colour buffer.
At least then you know your context and window creation is correct.

04-17-2011, 07:13 AM
Ok, although I was a 100% sure I had done everything like lesson 2 from NeHe, both in my project and lesson 1 from NeHe, and that I couldn't get lesson 2 showing anything yesterday, it seems that it works today. Sorry to bother you people.