PDA

View Full Version : Problem with glew, OpenGL 3.2 and linux



Junky
09-19-2010, 07:26 AM
Hi every one.

I'm using Ubuntu 10.04 64bits and I have Nvidia gtx 460 with newest drivers installed.

The problem is that if I use glew with an opengl 3.2 context the program crash (segmentation fault) when it calls gl functions (ex: glGenVertexArray()). But if I create an opengl 3.1 context or 2.2 the program works fine.
I'm using SDL to create the window and the context. And in windows XP works fine with opengl 3.2 context.

In an 3.2 context for example glGenVertexArray points to NULL.

Someone knows why it's happen?
I will apreciate some help.
It's better that I inicialitze opengl functions for my self without glew? How to do it?

Thanks.

PS: Sorry for my english :P

Nickolay Kolchin
09-19-2010, 10:14 AM
setup glewExperimental before GLEW initialization.



glewExperimental = GL_TRUE;
glewInit();

marshats
09-19-2010, 10:30 AM
What does glewinfo report ie on my Ubuntu I get


> glewinfo | less
---------------------------
GLEW Extension Info
---------------------------

GLEW version 1.5.5
Reporting capabilities of display :0.0, visual 0x2b
Running on a GeForce GTX 465/PCI/SSE2/3DNOW! from NVIDIA Corporation
OpenGL version 4.0.0 NVIDIA 256.53 is supported
...

And I have had no problem with SDL and glew for 3.2+ contexts on Ubuntu.

What video card do you have?

Junky
09-19-2010, 11:29 AM
glewExperimental = GL_TRUE; works for me! thanks.