PDA

View Full Version : nvidia wide lines bug in forward compatible 3.3



tksuoran
07-18-2010, 03:13 AM
Wide lines do not seem to work on nvidia with 3.1, 3.2 or 3.3 context forward compatible on. I have driver version 257.21.

Even though wide lines were gone in 3.0, they were put back in 3.1.

Ilian Dinev
07-18-2010, 06:16 AM
forward compatible on
They are disabled in such a context. It's written in the spec.

tksuoran
07-18-2010, 07:12 AM
Can you give me a pointer to that? I see that on page 344 of 3.3 specification lines wider than 1.0 are specified to cause an error for 3.0, while on page 355 it is specified that it is no longer an error in 3.1.

Ilian Dinev
07-18-2010, 04:35 PM
3.3 spec, page 342, read thoroughly
E.2.1 Deprecated But Still Supported Features

tksuoran
07-19-2010, 12:47 AM
Thanks! This makes it clear, so this certainly is not a bug. I see that in 3.1 wide lines were un-removed but not un-deprecated.

Now I suppose I need to use geometry shader to draw wide lines..

kRogue
07-19-2010, 02:38 PM
Um, a simpler solution would be to ask for a core profile but to NOT ask for a forward context. You get "deprecated core functions" i.e. glLineWidth. I can understand asking for a core profile, but is there a reason why you want a forward compatible context?

tksuoran
07-25-2010, 02:53 PM
I have absolutely no other reason, I just want to try out things forward compatible way.

I managed to get forward compatible wide lines working with a geometry shader. In case anyone is interested, I put it here:

http://neure.ath.cx/wideline.html