PDA

View Full Version : textureQueryLod on Catalyst 10.6



Foobarbazqux
07-02-2010, 02:20 AM
The ARB_texture_query_lod extension spec talks about a function textureQueryLOD, and the GLSL 4.00 spec talks about a similar function called textureQueryLod.(note the difference in CapiTALizatIOn).

I'm using Catalyst 10.6 on AMD64 Ubuntu.
These drivers claim to support Opengl 4.0 but if I try to use a shader with #version 400 that calls textureQueryLod I get shader compiler errors and the shader info log says
"No matching overloaded function found textureQueryLod".

On the other hand if I use #extension GL_ARB_texture_query_lod and textureQueryLOD, everything appears to work fine.

Alfonse Reinheart
07-02-2010, 02:37 AM
I'm using Catalyst 10.6 on AMD64 Ubuntu.

What hardware are you using?

Foobarbazqux
07-02-2010, 03:11 AM
I'm using Catalyst 10.6 on AMD64 Ubuntu.

What hardware are you using?
Radeon HD5770

Groovounet
07-02-2010, 03:43 AM
Yeap, that's a bug! I reported it to AMD too and it has been confirmed.

frank li
07-05-2010, 12:46 AM
textureQueryLOD is defined in the extension and textureQueryLod is defined in the OpenGL4.0/GLSL400. It's obvious that the Cat driver only derives the function from GL_ARB_texture_query_lod. It's an oversight in our job.
We will fix it soon. You could take the workaround way to make your program work as using textureQueryLOD under GLSL 400 before it gets fixed. Thanks for your feedback.