PDA

View Full Version : Why GLEW only report GL 3.1 on ATI catalyst 9.12(X



somboon
01-24-2010, 09:10 PM
The release note of catalyst claim that version 9.12 (windows XP) support OpenGL 3.2,but the latest version of GLEW only report OpenGL 3.1.

Is 9.12 doesn't support full OpenGL 3.2 spec or there are bugs on GLEW ?

Note that even thought GLEW only report GL3.1 but glGetString(GL_SHADING_LANGUAGE_VERSION); return version 1.5 , writing shader in GLSL 1.5 syntax (with out using deprecated stuff) also compile fine and give correct result.

nigels
03-04-2010, 08:27 AM
This is most likely fixed in GLEW 1.5.3
http://glew.sourceforge.net/

Groovounet
03-09-2010, 08:51 AM
Why GLEW 1.5.3 report OpenGL 3.2 with nVidia but only manage to load OpenGL 3.0 feature when we explicitely ask for an OpenGL 3.1 context instead of a OpenGL 3.2 context? A bug.

I don't know about implicit context creation, the behavious vary from plateform and apparently it should result in an OpenGL 2.1 context according to a Wine developer.

nigels
03-27-2010, 02:40 PM
A fix would be welcomed, of course. TOT in svn has initial OpenGL 4.0 support too.

nigels
05-07-2010, 04:43 PM
GLEW 1.5.4 is available.
http://glew.sourceforge.net/