View Full Version : Windows 7, XP drivers, Intel Chipsets and a mess.

10-27-2009, 12:17 PM
Hello there everybody.

I have been running XP Media Centre Edition for between three to five years on this computer (a Dell Dimension 1100) with no issues. One week ago, however, I upgraded myself to Windows 7.

I initially was left running in a 640 screen resolution, but soon fixed this by downloading the latest drivers for my Intel chipset (82865G graphics and memory controller). These drivers were for XP, so I had to install them in compatibility mode.

I am now in the correct (1024) resolution. However, several of my games do not function correctly, and I suspect this is due to OpenGL's abscence.

Quake 1: Launches and plays for ~1 second, crashes to desktop.
Quake 3: As Quake 1
Quake 4: As above

id-Tech3 based mods (EGL, Q2E): Error in launch console: "GLW_StartOpenGL: could not load OpenGL subsystem"

I have tried to update my drivers through Device Manager, but I am up-to-date. I have downloaded and installed DirectX11 and then DirectX9. I have searched for the correct OpenGL download. All to no avail.

Could you pelase point me to the OpenGL version I need to run these programs?

Help much appreciated, thanks in advance.

Stephen A
10-30-2009, 04:36 PM
Head to Intel's website and search for updated drivers.

12-17-2009, 09:23 AM
The newest drivers are still for XPMCE.

I'm getting the same errors on any of my Q3-based games now too. Which is a bit of a bugger because I mod one of them.

12-19-2009, 01:59 AM
I've discovered something very interesting. As of yesterday evening all my Quake games work perfectly, though JK3 (The Q3E-based one) still refuses to launch.

12-19-2009, 05:08 AM
Maybe driver needed a reboot to work.
No idea for JK3 ... Is there a startup log, showing some specific error ?

12-19-2009, 09:31 AM
One times Jedi Academy launch log.

JA: v1.0.1.0 win-x86 Oct 24 2003
Initialising zone memory .....
----- FS_Startup -----
Current search path:
C:\Games\Jedi Academy\GameData\base\zzzz_baseJOJA.pk3 (3072 files)
C:\Games\Jedi Academy\GameData\base\assets3.pk3 (16 files)
C:\Games\Jedi Academy\GameData\base\assets2.pk3 (62 files)
C:\Games\Jedi Academy\GameData\base\assets1.pk3 (8320 files)
C:\Games\Jedi Academy\GameData\base\assets0.pk3 (15346 files)
C:\Games\Jedi Academy\GameData/base

26816 files in pk3 files
execing default.cfg
execing jaconfig.cfg
execing autoexec.cfg
...detecting CPU, found Intel Pentium IV

------- Input Initialization -------
Skipping check for DirectInput
Joystick is not active.
----- Client Initialization -----
----- Initializing Renderer ----
----- Client Initialization Complete -----
--- Common Initialization Complete ---
Working directory: C:\Games\Jedi Academy\GameData
Initializing OpenGL subsystem
...initializing QGL
...setting mode 4: 800 600 FS
...using desktop display depth of 32
...calling CDS: ok
...registered window class
...created window@0,0 (800x600)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 32, 24, 8 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 32, 24, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (4)
...setting mode 3: 640 480 FS
...using colorsbits of 16
...calling CDS: ok
...created window@0,0 (640x480)
Initializing OpenGL driver
...getting DC: succeeded
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...GLW_ChoosePFD( 16, 16, 0 )
...35 PFDs found
...GLW_ChoosePFD failed
...failed to find an appropriate PIXELFORMAT
...restoring display settings
...WARNING: could not set the given mode (3)
...shutting down QGL
...unloading OpenGL DLL
----- CL_Shutdown -----
GLW_StartOpenGL() - could not load OpenGL subsystem

The first PK3 on the list is non-stock, but it's not caused the problem. the game is still broken without it, and it worked on my previos installation anyway.

12-20-2009, 10:30 AM
Issue fixed thanks to GLDirect, which essentially bypasses the need for OpenGL on my system.