PDA

View Full Version : Installation on Vista



felixlover
06-04-2009, 06:52 AM
What Iím trying to do: Use openGL

What Iíve done:
Installed Visual C++ 2008 express edition
Downloaded glu32.dll, glu32.lib, and glu.h

I have:
Windows Vista 64 bit with Service Pack 1
C:\WINDOWS\System32\ OpenGL.dll
glu32.dll, glu32.lib, and glu.h are sitting on my desktop

My problem is:
I keep finding that Iím supposed to download other files to go with the Visual C++ (such as glu32.dll, glu32.lib, and glu.h). I have these files, but I donít know where to put them. Also, Iím not sure if these are all the files I need (some sources donít mention other files, some sources advise loading many files). I tried to use Visual C++ earlier today, but couldnít get it to work as expected, so I uninstalled it and tried again.
Iíve tried

What Iím asking for:
Does anyone have EXTREMELY clear directions for the GLU files associated with Visual C++ 2008 express edition that are compatible with Windows Vista 64 bit? Iím very new to this side of computers (usually I write code on programs given to me by my teachers) so Iím looking for something fool proof, if itís out there.

Thanks,
Lucy

martinsm
06-04-2009, 06:55 AM
Why do you need to download glu32.* files?
glu32.dll already comes with OS. And lib/h files comes with Visual Studio 2008 EE.

felixlover
06-04-2009, 10:00 AM
When I build lesson1 from http://nehe.gamedev.net/data/lessons/lesson.asp?lesson=01 I get the following messages:

1>------ Build started: Project: Lesson01, Configuration: Debug Win32 ------
1>Compiling...
1>Lesson1.cpp
1>..\..\..\..\..\Desktop\Lesson1.cpp(9) : warning C4627: '#include <windows.h>': skipped when looking for precompiled header use
1> Add directive to 'stdafx.h' or rebuild precompiled header
1>..\..\..\..\..\Desktop\Lesson1.cpp(10) : warning C4627: '#include <gl\gl.h>': skipped when looking for precompiled header use
1> Add directive to 'stdafx.h' or rebuild precompiled header
1>..\..\..\..\..\Desktop\Lesson1.cpp(11) : warning C4627: '#include <gl\glu.h>': skipped when looking for precompiled header use
1> Add directive to 'stdafx.h' or rebuild precompiled header
1>..\..\..\..\..\Desktop\Lesson1.cpp(12) : warning C4627: '#include <gl\glaux.h>': skipped when looking for precompiled header use
1> Add directive to 'stdafx.h' or rebuild precompiled header
1>..\..\..\..\..\Desktop\Lesson1.cpp(404) : fatal error C1010: unexpected end of file while looking for precompiled header. Did you forget to add '#include "stdafx.h"' to your source?
1>Build log was saved at "file://c:\Users\Lucy\Documents\Visual Studio 2008\Projects\Lesson01\Lesson01\Debug\BuildLog.htm"
1>Lesson01 - 1 error(s), 4 warning(s)
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

I thought this would have something to do with the glu files. If it doesnít, do you have any other suggestions?

martinsm
06-04-2009, 11:49 AM
Read warning/error messages more carefully!

Add directive to 'stdafx.h' or rebuild precompiled header

fatal error C1010: unexpected end of file while looking for precompiled header. Did you forget to add '#include "stdafx.h"' to your source?

Simply disable precompiled headers in Project Settings, or do what error message tells you.