PDA

View Full Version : I am really confused



TheGolfball
05-08-2009, 09:45 AM
I am trying to compile an application from within QT Creator and get the following message: missing glu.h

I think that glu.h is part of OpenGL?

I am running Ubuntu Desktop 9.04 and have proprietary nVidia drivers installed ver 180.51. I don't know if OpenGL is installed and I have no idea about how it interacts with proprietary nVidia drivers or if they are even compatible.

So, I guess my coding related questions are:

1. Is glu.h part of OpenGL?
2. How do I get OpenGL installed on my computer?
3. Can I have both OpenGL and proprietary video drivers installed simultaneously?

Thanks.

ZbuffeR
05-08-2009, 10:24 AM
You have to understand that packages in a lot of modern linux distributions exists in separate 'default' (library, binary execution) and '-dev' or '-devel' (for source compilation) packages.

On my ubuntu 8.04, /usr/include/GL/glu.h is provided by libglu1-mesa-dev. Search for 'glu' in Synaptic packages manager, and install the -dev version.

TheGolfball
05-08-2009, 12:38 PM
Thank you.