View Full Version : Problems with laptop and open gl

04-26-2009, 03:13 PM

I've developed an opengl application which displays an altitude profile from a digital elevation model. It's working fine on desktop computers, but i've some problems on laptops. There is a lot of flickering, maybe some problem with buffer swapping.
I think it may be a driver related problem, is there an open gl test application to check for basic features? Laptops have intel graphic chipsets.
I use stencil buffer, viewport, well nothing really fancy...
any clue would be appreciated...

04-27-2009, 01:24 AM
I've disabled hardware acceleration, and it is now almost working.
I'm going to check laptop hardware compliance, the first result i got is everest.
Does anybody know of something more specific?

06-09-2009, 12:37 AM
If there is people interested, problem was with intel extreme graphics. This chipset obviously doesn't handle double buffering well.
If i use single buffering it is fine. I don't like this kind of specific setup but i've found no other way.

06-09-2009, 01:41 AM
If it can't handle double buffering its a bug. Intel is really bad with properly implementing OpenGL. do you have at least the latest drivers?

06-09-2009, 02:06 AM
yes i do. I don't blame intel, because it may be my fault. Opengl rendering is done inside an Ilog views container, but it works except on this particular chipset when HW accel is enabled.

06-09-2009, 03:09 AM
have you tested some other OpenGL applications or games like Doom3 / Quake4? OpenGL viewer has also some rendering tests: http://www.realtech-vr.com/glview/

06-09-2009, 08:54 AM
I've given up on finding the solution for the moment, so i've forced software rendering in the source code.
but thank you for your support, i'm going to try to run glview.