PDA

View Full Version : OpenGL 3.0/3.1 with Qt or GLUT



Amikam
04-25-2009, 02:11 AM
Hi all,

I have 3 questions:

1. In the case of NVidia drivers (Geforce 9): is it possible to access OpenGL 3.0/3.1 only threw WGL_ARB_create_context ?
If I print the value of GL_VERSION, I see OpenGL 3.0 without creation of RC using this extention.
2. Is it possible to use Qt and GLUT with OpenGL 3.0/3.1?
3. Is it possible to use WGL extentions when using Qt or GLUT?

Thanks

soconne
04-25-2009, 09:31 AM
I don't believe its possible with GLUT since you do not have direct access to the HWND, HGLRC variables created by GLUT on the windows platform. If you did and were able to modify them and have GLUT store the result, then you could create an OpenGL 3 context. I believe the same problem still applies to other platforms.

Amikam
04-25-2009, 09:53 AM
Thanks.
I have just discover that there is a new version for freeglut (2.6 RC) which use OpenGL 3.x.

Rosario Leonardi
04-26-2009, 11:25 AM
With wxWidget I have to derive from wxGLContext and create a custom context, I think you can find a similar solution with Qt.