PDA

View Full Version : Problems with refresh rate at rotation with mouse



Abschiedsstein
04-17-2009, 03:42 AM
Hello all,
i wrote a program in which it is possible to rotate the displayed image around all axes with the mouse(klick, hold and move).
I had a program using glut which worked really well, but I wanted to have bigger influence on certain transformations... Therefore I changed to basic opengl.
Now my problem is that there are only very few images displayed if I klick and move the mouse (about 1f/s). I dont understand this because i call my drawing function every time the program gets an WM_MOUSEMOVE message. The Depthbuffer is cleared at begin of this function...
I really have no idea how to solve this problem.
It would be great if you have any advices where I have to look...
If you need any code parts pls tell me... I did not want to post all 2000 lines.
Best regards and thank you very much!

ZbuffeR
04-17-2009, 04:53 AM
but I wanted to have bigger influence on certain transformations... Therefore I changed to basic opengl.
I do not see how 'basic opengl' would allow that ?

Abschiedsstein
04-18-2009, 01:36 AM
I wanted to have the opengl window as a child window inside a normal winapi window. I did not succeed in starting glut in that child window... there fore I did not use anymore glut. I created a winapi window and a child window and made the child window to the opengl window...this was no problem....I could also transfer most code parts from the old program...a single problem I could not solve is described above.