PDA

View Full Version : Shadow Texture not smooth



cherryyosh
02-20-2009, 01:00 PM
Hey guys, I had this problem before and managed to solve it however doing the same steps I cannot solve it this time, so I ask you again if you have any idea why these textures are not coming out smooth.

http://i19.photobucket.com/albums/b182/valeranth/Games/vsmError1.png

I don't know what code to provide, so tell me what you need or I can post the whole main.cpp

zeoverlord
02-20-2009, 05:37 PM
it looks like the texture is unfiltered, just turn on linear filtering and it might get better

cherryyosh
02-20-2009, 05:42 PM
I am using gl_NEAREST right now, I cannot use anything else due to the fact that im using GL_FLOAT (32F) so they do not support hardware filtering for speed.

zeoverlord
02-21-2009, 03:04 AM
then you have to do it within your shader manually

cherryyosh
02-21-2009, 11:34 PM
then you have to do it within your shader manually
How do I go about doing this in a shader??
EDIT: also just switched everything to GL_UNSIGNED_BYTE with GL_LINEAR, and the same thing happens

cherryyosh
02-22-2009, 11:46 AM
So its not letting me edit my last post, but heres what I have now, and the error still exist.

Depht map, GL_DEPTH_COMPONENT, GL_LINEAR, GL_FLOAT (not erroring now, so idk..)
vsm_tex (stores the moments),GL_RGBA, GL_LINEAR_MIPMAP_LINEAR, GL_FLOAT
blur (vsm_tex with a 3x3 blur), GL_RGBA, GL_LINEAR, GL_FLOAT

all are using GL_CLAMP..

I am completely lost -_-

IneQuation.pl
02-23-2009, 06:52 AM
Perhaps increase the depth precision?

cherryyosh
02-23-2009, 10:44 AM
Perhaps increase the depth precision?

The gpu should use the highest precision possible already...