View Full Version : Problem with window displaying.

01-21-2009, 04:40 AM
I'm having a problem running a program that I compiled on my eeepc. The program is the same as I run on the computers on campus, which works absolutely fine.

As they say, pictures speak louder than words:


Essentially, what's happening is the image sort-f appears on the screen, without the window frame. If I was to move a different window onto the image, the part that is overlapped disappears.

Plus, if I press any letter, 'Arghh' appears in terminal. I am using a procedure to display info, but only when w or p are pressed.

I did mess up Mesa, as I thought it had to install it, but ended up reinstalling Ubuntu (via terminal), which should have fixed Mesa.

01-21-2009, 05:13 AM
Try the suggestions related to OpenGL here : http://forum.eeeuser.com/viewtopic.php?id=32584

What eepc version and ubuntu version do you have ?

What *glut* package(s) are currently installed ?
Search for glut in the synaptic package manager (title only).

01-21-2009, 06:04 AM
Looking at that link, I have neither an Intel section in xorg.conf, or INTEL_BATCH=1 in environment. As I'm not exactly a Linux pro, how would I rectify these?

Ubuntu version is 8.10, desktop version.

The glut packages I have installed are:


01-21-2009, 09:33 AM
Problem solved. Simply had to disable desktop effects.

01-21-2009, 12:45 PM
Well, not really a solution, it is more a workaround.
The intel gma must be capable of running both compiz and your opengl program correctly.

01-21-2009, 03:25 PM
True, is only a workaround. But ubuntu is my secondary OS, only use it for programming, so I think I can cope without compiz.

If anyone does think of how to fix original problem, that would be great.

01-22-2009, 09:27 PM
Until recently direct-rendering and compiz did not play together at all. With DRI2 in xserver 1.6, it will "just work." If you fell like building the X stack (libraries, xserver, etc.) you can get it now. I think X.org 7.5 should be out pretty soon. At this point, I think we're mostly waiting for the release manager to get back from linux.conf.au.