PDA

View Full Version : Read back problem.. MX 440



muvee
09-05-2008, 03:49 AM
I have another problem on MX 440 card.

We try to save a few rendered frames into a video stream.

We first do off-screen rendering to a hidden window and read back from it. The read back data is wrong or corrupted only on MX440 so far. It seems as if the hidden window area of the desktop (frame buffer) gets read back. As a result, if I move another window (e.g. taskmgr or notepad) over the hidden window area while it is saving, those windows are seen in the saved result. What's more, if screen saver starts while the application is saving, that portion of the screen saver corresponding to the hidden window gets saved as well.


So, I made the hidden window SHOWN. It's shown upon creation and I can see the rendering works fine while it's saving. But, if I still move another window over my rendering window, it's reflected in the read back or saved result. Based on this, I guess it's a read back issue on MX 440 card.

Any suggestions? Thanks!

ZbuffeR
09-05-2008, 05:59 AM
Unless you use pbuffers or FBO, this is normal behaviour.

Zengar
09-05-2008, 07:59 AM
To further explain ZbuffeRs answer: the OpenGL specification states that hidden/overlapped parts of a window contain undefined data.

ZbuffeR
09-05-2008, 10:15 AM
Sorry, my reply was indeed too terse for the beginner board, I have to be more carefull :)

muvee
09-09-2008, 12:22 AM
Thanks guys. This problem is solved. Something messed up when we create the pbuffer (wglCreatePbufferARB()).

By the way, pbuffer is supported as long as the extension "WGL_ARB_pbuffer" is present on Windows (since OpenGL v1.1), correct?