PDA

View Full Version : Flickering Problem with Display Lists



jcoplan
04-29-2008, 12:22 PM
Hey,

I'm running into a problem with the display lists I'm using. Fundamentally the problem is that when I use display lists for the object I am trying to render, the objects flicker and are drawn incorrectly. When I invoke the drawing code directly there are no problems.

Here are two pictures of the objects, one drawn correctly and one drawn with display lists.
http://www.cs.rit.edu/~joc0225/BeachBalls1.JPG
http://www.cs.rit.edu/~joc0225/BeachBalls2.JPG

The objects that I'm drawing are spheres. I want certain slices of the spheres to be gray and other parts to be white. To do this I am using two clipping planes to cut the sphere into the portions I want and draw it 4 times with the desired colors.

Also I did not run into this problem when drawing the objects on my Macbook Pro. I am running into these problems on an Intel 82915G/GV/910GL Express Chipset.

Any help here would be much appreciated.

Thanks
Justin

jcoplan
05-06-2008, 08:19 AM
So no one's run into anything of this sort?

ZbuffeR
05-06-2008, 08:51 AM
Not to my knowledge.
But you are going a strange route, and the minimal Intel graphic "accelerators" (as they call it) is quite likely to have a couple of problems with it.

Maybe you abuse too much of pushmatrix/popmatrix, and your hardware does not support so many levels ? Try putting glGetError somewhere, and be sure you have no gl error. GlIntercept is also a good tool to debug GL code, but I think it is only released for Windows.