View Full Version : ERROR: Missing GL version

03-06-2006, 11:06 AM
I'm a beginner programmer trying to get my first shader to run in my OpenGL application.

I have included <GL/glew.h> (before glut), installed the dll file into SYSTEM32, the glew32.lib in LIB and glew32.h etc in include. I have also set linker to read glew32.lib

I run this code in my main function to identify the problem:

/************************************************** ***********/

int main(int argc, char *argv[])
glutInit(&argc, argv);

GLenum err = glewInit();
if (GLEW_OK != err)
fprintf(stderr, "Error: %s\n", glewGetErrorString(err));
fprintf(stdout, "Status: Using GLEW %s\n", glewGetString(GLEW_VERSION));

...etc etc...(but it doesn't get this far)

it returns the error message:

ERROR: Missing GL version

I'm really stuck as what to do now, any help would be much appreciated.

Thanks :confused:

03-06-2006, 11:54 AM
You have to initialize glew after you have created OpenGL context.
So you must initialize glut, create window, and then initialize glew.

03-06-2006, 02:31 PM
That's brilliant! It worked, thankyou very much for that tip.