PDA

View Full Version : FBO



H.Stony
03-04-2006, 03:34 PM
how to use it?

glGenFramebuffersEXT
glGenFramebuffersARB
glGenFramebuffers

no of them is defined...xcode 2.2 os10.4.3

---> can't find it in the gl.h?

H.Stony
03-04-2006, 03:55 PM
it seems that apple has to update the gl.h...

here is the solution: http://www.idevgames.com/forum/showthread.php?t=10670

how can i avoid to use glew or something like that?

OneSadCookie
03-04-2006, 04:47 PM
The functions are in my glext.h (Mac OS X 10.4.4, Xcode 2.2).

glext.h is included by gl.h on 10.4, so you shouldn't have to do anything special.

H.Stony
03-05-2006, 01:04 AM
very strange - it seems that i have not the latest opengl.framework. but xcode package is definitly 2.2.
my glex.h starts with: Copyright: (c) 1999 b...

can't find the downloadable framework somewhere. is there a download possibility or could you share me your glext.h?

OneSadCookie
03-05-2006, 09:36 PM
I'd suggest that if your OpenGL framework headers are not correct, that you have worse problems than can be solved by my giving you headers ;)

Make sure you're using <OpenGL/gl.h>, not the <GL/gl.h> that's in /usr/X11R6/include.

I've put my OpenGL.framework's headers at http://onesadcookie.com/~keith/OpenGLHeaders.zip

H.Stony
03-06-2006, 08:04 AM
i am using the correct headers but it is just not defined in there (glext.h)

your package only contains an alias to your files....

OneSadCookie
03-07-2006, 09:05 PM
uh, whoops.

Try that again :)

H.Stony
03-09-2006, 09:22 AM
thanks. very strange - don't know why my .hs have'nt been updated correctly.

the fbo works now but the program crashes if i use a glClear call after glBindFramebufferEXT

OneSadCookie
03-10-2006, 01:37 AM
There was a thread about that on the mac-opengl list recently. Archives are at http://lists.apple.com/ . IIRC, it turned out to be an NVidia-specific bug.