PDA

View Full Version : glBitmap works different on PPC and Intel ?



vbovio
05-28-2007, 08:44 AM
Hi,

I have an application where I draw points as symbols (triangles, diamons, etc) using glBitmap, in Mac PPC, those symbols are drawn in correct depth order, like any other primitives, but in Mac Intel they are rendered in top of other primitives.. think of a shaded box, in PPC only the front vertex points are seen, but in Intel all are seen.. why is this ??, is there a setting that is enabled in Intel that is not on PPC or something like this ?..

Thanks.

arekkusu
05-28-2007, 12:09 PM
What video card and OS are you using on PPC, and on Intel?

Do you have a depth buffer?
Is depth testing enabled?
Is the rasterpos Z set correctly?

vbovio
05-28-2007, 02:07 PM
What video card and OS are you using on PPC, and on Intel?PPC:
OpenGL RENDERER = ATI Radeon 9600 OpenGL Engine
OpenGL VERSION = 1.5 ATI-1.4.18
Intel:
OpenGL RENDERER = Intel GMA 950 OpenGL Engine
OpenGL VERSION = 1.2 APPLE-1.4.52

Mac OS X 10.4.9 for both

Do you have a depth buffer?yes

Is depth testing enabled?yes

Is the rasterpos Z set correctly? yes

James W. Walker
05-29-2007, 07:59 PM
I can't think of any reason why PPC and Intel should be different. More obvious things to check: Is the depth function GL_LESS or GL_LEQUAL? Is blend mode disabled?

vbovio
05-30-2007, 09:43 AM
depth function is GL_LESS, but I tried it with GL_LEQUAL and I get the same result. Blend mode is disabled.
any other idea ?

by the way, I changed to glDrawPixels instead of glBitmap, and now it is in the correct depth order (with other primitives), unfortunately, I have to use glBitmap..

Thanks.

James W. Walker
05-30-2007, 12:32 PM
I suppose it could be a bug in the driver. You could ask on the Mac OpenGL mailing list (http://lists.apple.com/mailman/listinfo/mac-opengl) . If desperate, you could spend a tech support incident with Apple DTS.

darrenc
07-26-2007, 12:49 PM
I am seeing the same issue (and would very much like to use glBitmap() over glDrawPixels() as well).

Have you seen any movement, made any inquiries through other channels?

vbovio
08-02-2007, 09:08 AM
No, I did not made any inquiries about it.. the problem was using an Intel MacBook (don't have it anymore).. but now I'm using a MacBook Pro and it does not have that problem..

this one is:
OpenGL RENDERER = NVIDIA GeForce 8600M GT OpenGL Engine
OpenGL VERSION = 2.0 NVIDIA-1.5.2

If you check the above posts, the mackbook looks like has an Apple driver, maybe complain with theme until you get an answer, :-P

darrenc
08-06-2007, 06:05 PM
I am fairly convinced it is a driver problem with the Intel GMA 950. Thanks none the less.

arekkusu
08-06-2007, 09:17 PM
Please file a bug. (http://bugreport.apple.com)
A sample application is helpful but not required.