PDA

View Full Version : Problems with Running OPenGL in Linux Machines.



arnott
06-21-2000, 09:26 AM
Hi All,
We were running OPENGL programs in SGI and Linux machines .we got new linux(6.1) boxes from Dell and we Installed Mesa 3.2 in them and tried to run OpenGl in it.we had some problems like

GLUT : Fatal error in a.out : OpenGL GLX extension not supported by display : 0

we tried to set the DISPLAY to the IP address of the machine and run the program.
xlib : connection to "IP address" refused by server
xlib : Invalid MIT-MAGIC-COOKIE-1 key
GLUT : Fatal Error in a.out: could not open display : IP address

what is the problem ? how to make it work ?

we set the display with set DISPLAY=IP:0

waiting for ur answers.

thanks
arun

jmeinhorn
06-21-2000, 09:39 AM
What version of X are you trying to run on and what kind of video card. Most likely you will need to use XFree4.0 if you want any decent hardware excelleration.

arnott
06-21-2000, 12:31 PM
version of X = X11R6
video card = Diamon Viper V770D

Are these not suitable to run Linux ?

waiting for ur reply.

thanks
arun

jmeinhorn
06-21-2000, 01:11 PM
In order to see what X server you are running you can type 'X -version' usually this is found in /usr/X11R6/bin. You are probably running like 3.3.5 or something and you will probably want to install 4.0. As for your video card, I'm not sure what chipset the Viper 770D uses and I think it might be a TNT2 chipset(thats good). So then you will want to make sure to checkout nvidia's site for upgrading your xserver.

06-22-2000, 06:41 AM
Thanks for the tips.
Our X server version is XFree86 3.3.31b(88b).
The video card's chipset is TNT2. Should we upgrade our X server or could there be any other problems?

Thank you http://www.opengl.org/discussion_boards/ubb/smile.gif

MC
06-22-2000, 07:31 AM
1- Upgrade your X server to Xfree4.0
2- Install the NVidia server and kernel module (version 0.93)

Use the nvidia faq to set up properly OpenGL. Most problems comes from missing links and library conflicts.

But beware that most hardware accelerations are usable only when server and client are on the same machine.

jmeinhorn
06-22-2000, 11:06 AM
http://dri.sourceforge.net/resources/resources.html

If your going to do development you will need the libGLU.so, libglut.so and glu.h, glut.h from the think above.

06-24-2000, 01:14 PM
Originally posted by arnott:
Hi All,
We were running OPENGL programs in SGI and Linux machines .we got new linux(6.1) boxes from Dell and we Installed Mesa 3.2 in them and tried to run OpenGl in it.we had some problems like

GLUT : Fatal error in a.out : OpenGL GLX extension not supported by display : 0

we tried to set the DISPLAY to the IP address of the machine and run the program.
xlib : connection to "IP address" refused by server
xlib : Invalid MIT-MAGIC-COOKIE-1 key
GLUT : Fatal Error in a.out: could not open display : IP address

what is the problem ? how to make it work ?

we set the display with set DISPLAY=IP:0

waiting for ur answers.

thanks
arun

i think you forgot to load glx when starting X... you have to place something like this in the Modules Section of your XF86Config: load "glx" . sorry, i'm not exactly shure how its done with xfree 3.3.x im using 4.0...

arnott
06-27-2000, 05:09 AM
hi
we fixed the problem.it was not due to the x-term vision.the computers we got from Dell came installed with Red Hat 6.1 , but all the features were not installed properly.
so when we tried installing all features from red Hat 6.2 , we were able to run opengl.

thanks.
arun