View Full Version : eyelinear texturemapping, with glsl in driver 8756 ...wont work :(

04-24-2006, 11:27 AM
i posted this problem on gamedev.net forum a few
days ago. but i have gotten no answers so far. im hoping for better luck here.

im having some problem with my shadowmaping.
im using automatic eyelinear texture maping to map my shadowmap on the gameworld. this works fine. at least it did in the past. last week when i updated my driver to the latest 8756 driver everything went crazy. if i disable my glsl program and do the eyelinearmaping with fixed fuction everything works fine. but when i try to do it with a glsl vertexshader it doesnt work.
i have tried lots of different ways to get it to work. the only thing that works is.

vec4 kShadowUV = gl_Vertex * kEyePlaneMatrix;
where kEyePlaneMatrix is the eyeplanematrix for the shadowmap. this works .. for objects located at 0 0 0 but surprisingly not for other objects.

if i try to do like this
kVertex = gl_ModelViewMatrix * gl_Vertex;
vec4 kShadowUV = kVertex * kEyePlaneMatrix;

it doesnt work.

my old code that did work before driver 8756 just did it like this.
kVertex = gl_ModelViewMatrix * gl_Vertex;
vec4 kShadowUV = kVertex * mat4(gl_EyePlaneS[3],l_EyePlaneT[3],gl_EyePlaneR[3],gl_EyePlaneQ[3]);

but that doesnt work anymore. =(.

i tried to use 3dlabs glsl generator. and it generated something like this.
kShadowUV.s = dot( kVertex, gl_EyePlaneS[3] );
kShadowUV.t = dot( kVertex, gl_EyePlaneT[3] );
kShadowUV.p = dot( kVertex, gl_EyePlaneR[3] );
kShadowUV.q = dot( kVertex, gl_EyePlaneQ[3] );

but that didt work either =/.

so whats wrong =(. has anyone else experienced any problems like this with the latest nvidia linux driver? again it worked fine on earlier drivers and also it works fine without any vertexshader. also it works fine on the latest windows drivers to as far as i know.