PDA

View Full Version : Nvidia/ATI driver issues



john
04-09-2003, 10:58 PM
Hello,

this is largely off-topic and definately the wrong forum, but today has caused much frustration so I thought I'd tell everyone in the hope that someone from ATI reads this;

I've installed both NVidia and ATI drivers in my lifetime under Linux RH8. Nvidia drivers took all of 2 minutes to install; ATI drivers took me and my colleague MOST OF THE @#&*&$ DAY. ARgh.

ATi's webpage on linux support sux0rs!! fglrxyadayada.rpm isn't mentioned on the "here are our linux drivers"; it could only be found by google searching ati's website when we found another forum that mentioned we needed it. XFree4.3.0 got confused about the DVI port on the card (it saw it as another device without a description and panicked). In the end, I upgraded to XFree86_4.3 from 4.2, then downgraded when i found out about fglrxinfo, then had to boot to dos and flash the BIOS on my card because fglrxinfo reckoned I had a third party card (which I did) and so it didn't want to start. It also took ages to sort out why GLX was trying to access screens that didn't exist. It only worked in the end after a lot of trouble.

Suggestion to ATi: make your Linux driver info _useable_ rather than "we tell third parties to support it. <shrugs>". at *least* link fglrxinfo into the page!

btw, I am not advocating nvidia is BETTER than ATi; I am just after hetereogeneous environments. Nvidia's linux distro is still much MUCH nicer to work with.

cheers
John


[This message has been edited by john (edited 04-10-2003).]

vincoof
04-09-2003, 11:22 PM
You're right about the fact that nVidia's linux support is much better than ATi's, actually.
But why is this thread posted in the OpenGL coding forum ? I think you would have more interesting replies if it was posted in the OpenGL Linux forum.

[This message has been edited by vincoof (edited 04-10-2003).]

john
04-10-2003, 12:24 AM
well, it works now, so I am not really after "this is what yuo need to do"; I jsut want to tell ATI guys to fix their webpage, or at least add a "what to do when GLX segfaults when you run startx"

azcoder
04-10-2003, 03:06 PM
FYI - For ATI On Linux, you can always buy the XiG drivers from www.Xig.com. (http://www.Xig.com.) They are easy to install. They even have hardware support for VAO.:-)

richardve
04-10-2003, 06:00 PM
Originally posted by azcoder:
FYI - For ATI On Linux, you can always buy the XiG drivers from

Argh, don't say things like that, it's baaaŠŠad!

Drivers should be free, hardware is already way too expensive.

(and 'nvidia-installer --force-update' rocks http://www.opengl.org/discussion_boards/ubb/smile.gif)


[This message has been edited by richardve (edited 04-10-2003).]

freto
04-10-2003, 10:07 PM
I made the same mistake, I upgraded to RedHat 9.0 which has XFree 4.3. The ATI drivers for the Radeon 9700 are only working up to XFree 4.2. There are no 3D accelerated drivers for the Radeon 8500 or 9700 at present. Is there a specific problem with XFree 4.3 so ATI cannot produce a driver?

kansler
04-11-2003, 03:16 AM
I don't think OS specific questions should be posted in this forum. But as long as we're at it...

This just proves linux has a long way to go before it can really be considered a substitute for windows.

And really, BUYING a driver for linux? Isn't that the same as buying a Whopper and having to pay $5 to eat it?

Thaellin
04-11-2003, 04:05 AM
Hi All,

Regarding the web site:
1. http://www.ati.com
2. under "Built by ATI" click 'find a driver'
3. In the drop-list choose 'Linux/XFree86'
4. Choose your product, agree to the EULA...
5. Download the driver (fglrx).

You're right, though - the driver complains if you try to run it on XFree86 4.3. Right now, I'm using the DRI project's Radeon driver (the R200 flavor, since it seems there are two) for my 9000 under Linux and it works pretty well (odd intermittent texture issue, but actually better than fglrx in many places). DRI's radeon provides 3D acceleration for R200, RV250 and M9 chips - sorry R300+ users...

The main trouble I have with the DRI driver is no access to the GL extensions that I bought the card intending to play with. Pbuffers, vertex shaders, occlusion queries... not present.

Feel free to send letters to ATI asking them to contract for 4.3 driver development. They don't know you want them if they don't hear loud noises.

-- Jeff