PDA

View Full Version : Difference among the versions 1.5.0 and 1.5.1



Renato
06-24-2004, 12:06 AM
I have created an input 3d with the opengls, to recognize the object aimed by the mouse I have used the function GL_SELECT and medium the distance from the television camera proceeds the coordinate 3D using glunproject.

Up to the version 1.5.0 all works well.
With the version 1.5.1 don't work anymore.

Do you know what has been modified in this last version? :confused:

ZbuffeR
06-24-2004, 11:17 AM
I don't think there is such a GL version. The numbering is MAJ.min only. And even then, it should be compatible. More details about where you get your 'version' from ? Video card/driver/OS/etc ?

Relic
06-24-2004, 11:41 PM
Nope, see GL 1.5 specs chapter 6.1.11:
"the VERSION string is laid out as follows:
<version number><space><vendor-specific information>
The version number is either of the form
major number.minor number or
major number.minor number.release number,
where the numbers all have one or more digits. The vendor specific information is optional. However, if it is present then it pertains to the server and the format and contents are implementation dependent."

I don't think that the OpenGL version has anything to do with the original problem, only that a newer driver does something differently/wrong(?) in the example.

Put some code to analyze.

zeckensack
06-26-2004, 06:29 AM
Current NVIDIA drivers (60 series) report 1.5.1. Series 50 reported 1.5.0. So you're having a problem with new (unofficial) drivers, not with a particular GL version.