PDA

View Full Version : Radeon 9700 & PBuffers



marcdp
12-04-2002, 07:40 AM
I'm using Pbuffers for a render-to-texture effect in a game we're working on, but I'm having problems with it on the 9700 card.

In our game, we render the scene to a texture (the pbuffer) and then use that texture for some blurring effects by layering it multiple times on the screen. It works perfectly on a GeForce4, but whenever I try testing it on the 9700, the render-texture acts like it's getting lost when it's selected a second time. I can use the render-texture to render as many polys as I want as long as I don't call glBindTexture on it more than once. Once I call it a second time, the polys show up white (almost as if I had passed in a null pointer) until I regenerate the render-texture. Just to make sure it wasn't getting lost somewhere else in the code, I tried calling glBindTexture twice in a row and rendering a poly using the texture and it never shows up. If I remove the second glBindTexture, it does show up.

Has anyone else experienced this? I tried it on two different computers with a 9700 installed and had the same problem on both. But on the GeForce it works fine. I there an attribute that I may be leaving off when creating the pbuffers that could cause this, or is there something else I'm not thinking of?

Thanks for any help,
Marc

NitroGL
12-04-2002, 08:25 AM
There are some bugs with PBuffers and WGL_ARB_r_t on the 8500 and 9700. Most of them have been worked out in later drivers though.

Which driver set are you using?

Humus
12-05-2002, 12:26 AM
Try turning off FSAA and see if it helps. I need to turn it off in the current drivers for rendering to texture to works as supposed.

PH
12-13-2002, 01:55 AM
I just ran into this problem 5 minutes ago. I have two color buffers of a pbuffer bound to textures. But before I need them, I bind another texture ( standard ) and perform a glCopyTexSubImage2D operation. This is where it breaks down. If I don't use glCopyTexSubImage2D but rather a second pbuffer for this step, everything works. Note: the copy step is to a standard 2D image, not a bound pbuffer color buffer. On GeForce3 both methods work as expected.


[This message has been edited by PH (edited 12-14-2002).]