PDA

View Full Version : VBO + selection buffer = crash on NV 56.64



BobJelly
03-31-2004, 12:24 PM
Hi all,

I've been using ARB VBO for a while now, but yesterday I ran into a strange problem... I've added selection to my editor and when rendering in GL_SELECT mode I get a crash in nvoglnt.dll after a call to glDrawElements (using VBO)... I'm using the latest driver version (56.64). I tried the app on a lot of configuration and got the crash with all GeForce... (same drivers... not very surprinsing). I've also tried on a Radeon 9600 XT and everything was ok.

I'm pretty sure my use of VBO is correct as i've been using them for a while now and had no problem. I'm also confident in my selection buffer code, as I already used it succesfully in another projet.

Anyone ran into this kind of behavior ? Sounds like a driver bug to me but I could be wrong. I really don't know what to do now...

Thanks for your help!

evanGLizr
03-31-2004, 03:37 PM
Originally posted by BobJelly:
Hi all,

I've been using ARB VBO for a while now, but yesterday I ran into a strange problem... I've added selection to my editor and when rendering in GL_SELECT mode I get a crash in nvoglnt.dll after a call to glDrawElements (using VBO)...

[...]

Anyone ran into this kind of behavior ? Sounds like a driver bug to me but I could be wrong. I really don't know what to do now...

Thanks for your help!The spec doesn't say anything about interactions with selection mode, so it sounds like a driver bug to me, but I'll throw some ideas just in case any works around the problem.

Have you tried modifying the creation parameters of the VBO? Maybe you created it in such a way that the CPU cannot read the geometry.
Note that OpenGL selection rendering mode is normally implemented in software, so the CPU must be able to access the geometry.

Mapping the buffer before getting into selection mode may also fix it.