PDA

View Full Version : Render To Texture on nVidia



Emanem
09-09-2004, 01:14 AM
Hi, in ordert to use Render To Texture extension I wrote this code (http://utenti.lycos.it/emanem/code.jpg) .

On ATi it works fine, under nVidia (6800 GT with gl 1.5.1) not...
Which extensions should I search for to verify harware is 'WGL_ARB_render_texture' capable?

Bye, Emanem! :D

Relic
09-09-2004, 03:44 AM
What exactly fails?
Means, I see no reason for this to not work by the informations given.

Watch out, your algorithm to find extensions is not safe. strstr() returns the first occurance of a string. You cannot distinguish two extensions with the same prefix like GL_XYZ_bla and GL_XYZ_bla2 if you search for GL_XYZ_bla.

Emanem
09-09-2004, 11:28 PM
Originally posted by Relic:
What exactly fails?
Means, I see no reason for this to not work by the informations given.

Watch out, your algorithm to find extensions is not safe. strstr() returns the first occurance of a string. You cannot distinguish two extensions with the same prefix like GL_XYZ_bla and GL_XYZ_bla2 if you search for GL_XYZ_bla.What fails?!?!

With the 1.5.1 OpenGL drivers from nVidia it tells me that the extension 'WGL_EXT_extensions_string' and even the 'WGL_ARB_extensions_string' is missing!
On ATi I have the first, on nVidia not!
Is there someone who has developed succesfully a software with these extensions on nVidia?
Becuase I don't know what to do...

Byez, Emanem! :D

Ps. The fact that I use strstr is anyway good because I search for the full-qualified extension string.

-NiCo-
09-09-2004, 11:52 PM
I experienced the same problem on a GF 6800 GT with driver versions 61.76 and 61.77
Both the render to texture extensions and the pbuffer extension were missing.

All versions from 62.20 and up solved the issue.

Later I tried reinstalling 61.77, but by using Detonator Destroyer to remove any existing nvidia driver files before installing the driver. This seems to work.

Greetz,

Nico

ffish
09-10-2004, 12:26 AM
Emanem, try GLEW or another extension wrapper. GLEW is very easy to use and a small download. It works fine with WGL extensions as well as plain GL extensions. Never had a problem with any drivers since I started using it. That includes 61.76, 61.77 right up to the newest beta dev drivers. render_texture and pbuffer both work fine.

jar/science
09-10-2004, 05:59 AM
Although I use GLEW and I correctly get all the pbuffer etc. extensions IMHO something is definetly strange about that 61.77 driver:
I tried to use pbuffers with this driver on a GeforceFX and I get random black blocks destroying the pbuffer contents when rendering a 3d scene into it.
If I disable the GL_DEPTH_TEST everything works fine.
I tested it with older drivers on a Geforce3 (56.xx) and an ATI9700 and the results are correct (with GL_DEPTH_TEST enabled).

I am not fiddling around with stencil/alpha testing, so it shouldn't come from that..

I heard of similar problems on other forums.
Someone "solved" the problem by changing the quality/performance settings...

Any suggestions?

Emanem
09-10-2004, 06:54 AM
Originally posted by -NiCo-:
I experienced the same problem on a GF 6800 GT with driver versions 61.76 and 61.77
Both the render to texture extensions and the pbuffer extension were missing.

All versions from 62.20 and up solved the issue.

Later I tried reinstalling 61.77, but by using Detonator Destroyer to remove any existing nvidia driver files before installing the driver. This seems to work.

Greetz,

NicoMany thnx Nico!

Today I'll ask my friends to update thier drivers
to catch this issue.
Let's see what happens!

Byez, Emanem! :D

Ps. I don't use any of these EXT loading libraries because I need just small extensions loaded...I do 'by hand'! ;)

ffish
09-10-2004, 06:59 AM
Search the internet for newer drivers? There are places that host leaked drivers. FWIW I have heard of problems with 61.76 & 61.77, the same sort of problem as you had as well as other problems. I never had any myself and I used them for a while. I'm sure that there are new official drivers on the way soon. I just had a look and saw 66.31 is available amongst others. I'm using a different 66 series driver and no problems.