PDA

View Full Version : NV_float_buffer and GLSL



KRONOS
05-25-2004, 07:25 AM
I'm trying to use NV_float_buffer with GLSL. I know that the spec requires the use of NV fragment programs to write and read data from the float color buffer and texture. But, since I didn't want to have to write more fragment programs, I've tried with GLSL, but it doesn't seem to work.
As anyone ever tried to use GLSL and NV_float_buffer and actually worked? Because if it did, then I'm doing something wrong...
I'm using Det 56.72 on a FX5700.

jra101
05-25-2004, 07:43 AM
NV_float_buffer should work fine with GLSL.

Can you describe specifically which problems you are seeing? Are you checking for OpenGL errors in your app?

KRONOS
05-25-2004, 02:41 PM
Originally posted by jra101:
NV_float_buffer should work fine with GLSL.

Can you describe specifically which problems you are seeing? Are you checking for OpenGL errors in your app?The problem is I only see black! :D
I do check for erros in some places. I'm probably just missing something... :D (hum, GL should really have a better error handling mechanism)

KRONOS
05-26-2004, 12:35 AM
OK, got it to work. :D (it was a stupid error)

But now I have a question! I'm doing a first pass where I draw everything to the z-buffer and with glColorMask(FALSE,FALSE,FALSE,FALSE), to the FP p-buffer. I tought I wouldn't need any fragment program (in this case a GLSL shader), because nothing gets actually written to the color buffer. But it needs to have a fragment program active. I've read the NV_float_buffer spec and didn't saw anything relating to this and it seams a bit strange to me this behavior.