View Full Version : GL_DEPTH_TEST question

04-10-2001, 06:22 AM
if i have a triangle strip that intersect with another triangle strip: when i move the camera, near the intersection between the two triangle strips, fps drops down from 100 to 50 ! I think this is because of the GL_DEPTH_TEST , but of course i need to use it. is this normal ? or i'm missing something ?

04-10-2001, 06:29 AM
A guess is that since you are moving toward the triangle fans, there happens to be more fragments fighting in the depth buffer than if further away.

I'm not sure if that should account for a 100fps to 50fps drop though.

04-10-2001, 07:20 AM
maybe the fillrate is the bottleneck here? If the triangles are zoomed, they took more place on the screen, so more pixels have to be drawn. Check it,just reduce the window size (screen resolution at fullscreen).
Also in the case with Radeon cards, there is a bigger chance to Hyper Z cache miss, I think...

04-10-2001, 11:26 AM
i think it's actually because opengl tries to break up the intersecting triangles into smaller triangles (it does this instead of drawing one or the other)...could be something else in combination though

04-12-2001, 03:17 AM
If you enlarge primitives fillrate always comes into play at some point.
The numbers 100 and 50 fps sound suspiciously like vsync enabled! The bigger primitives may take longer than 1/100 sec to draw thereby you miss one monitor refresh and framerate halves.

04-12-2001, 04:45 AM
Relic, so I should try to render the double of triangles but half smaller ?