PDA

View Full Version : Performance of GL_ARB_depth_texture on Radeon 9700



kaib
08-22-2003, 10:25 AM
Hello,

I'm copying the depth buffer to a texture using glCopyTexImage*, and GL_ARB_depth_texture, GL_ARB_shadow extensions on a Radeon 9700 Pro card.

However, my very simple app runs at 6fps! What is the expected performance of using these extensions on this video card?

The system is a P4 2.4 GHz, with 1GB memory.

Thanks.

Ostsol
08-22-2003, 10:47 AM
Turn off FSAA. I've had the same problem and reported it to ATI dev relations. They responded, but didn't give any explanation.

PanzerSchreck
08-22-2003, 11:03 AM
I have discovered the same "problem" in my own shadowmap-demo some time ago (also posted it here).It runs awfully slow when turning on FSAA if you use simple Render-To-Texture.
Change your application to use PBuffers instead of simple Render-To-Texture, and you should get better performance.

kaib
08-22-2003, 02:50 PM
Thanks for the advice.

Just so people know, using Catylyst 3.2 in display properties, I set the Anti-Aliasing to 'Application Preference' (which for my application disables FSAA), and now get 900fps.

Before, it was set at 4xAA.

Thanks again for the help.

PanzerSchreck
08-23-2003, 12:21 AM
Just to let you know : 'Application Preference' means that AA is turned off.

PanzerSchreck
09-07-2003, 02:16 AM
Sorry for digging this topic up, but as it seems, ATI have fixed this problem with their latest Catalyst 3.7!
I just tested it with my own shadowmap-demo, that now runs with active 4xAA at about 80fps, whereas the same AA-setting under Catalyst 3.6 would cause it to crawl down to about 3-4fps!

zeckensack
09-07-2003, 05:36 AM
Originally posted by PanzerSchreck:
Sorry for digging this topic up, but as it seems, ATI have fixed this problem with their latest Catalyst 3.7!
I just tested it with my own shadowmap-demo, that now runs with active 4xAA at about 80fps, whereas the same AA-setting under Catalyst 3.6 would cause it to crawl down to about 3-4fps!This may be the same "UT2k3 character shadows with AA" thing that has been mentioned in the 3.7 release notes http://www.opengl.org/discussion_boards/ubb/smile.gif

Ostsol
09-07-2003, 10:07 AM
Originally posted by zeckensack:
This may be the same "UT2k3 character shadows with AA" thing that has been mentioned in the 3.7 release notes http://www.opengl.org/discussion_boards/ubb/smile.gif
Those shadows didn't appear to use depth textures, though. . . Perhaps the real issue was with slow framebuffer reads. . .