PDA

View Full Version : Please can you test this program?



Sansus
01-27-2002, 04:50 AM
I have downloaded a program that uses WGL_ARB_buffer_region but it does not run well. I have a Geforce2. Can you test it?

Here is the program: http://www.delphi3d.net/download/bufferregion.zip

Thx.

GPSnoopy
01-27-2002, 05:05 AM
Here is what I get: http://users.pandora.be/tfautre/bufferdemo.png


I have a P3 700, GeForce 2 U (D 23.11), WinXP btw...


[This message has been edited by GPSnoopy (edited 01-27-2002).]

Sansus
01-27-2002, 05:19 AM
But, why? I also get a perturbed image, but the author says it works fine.
Maybe any driver problem?
I have a Athlon 1400 WinXPpro, Geforce2 GTS and the last detonators.

Nutty
01-27-2002, 06:21 AM
I get the same effect as GPSnoopy with GF3, and 27.00 drivers.

richardve
01-27-2002, 07:09 AM
Same here.. (but it's purple instead of grey)

GeForce3 Ti 200 - Det 23.12

mightyMo
01-27-2002, 08:06 AM
ATI works fine.

Also I have a Geforce 2 with old 12.41 drivers. This works. This looks to be another case where Nvidia broke stuff in this huge performance kick they've been on recently.

harsman
01-27-2002, 10:56 AM
Doesn't work here either.

GeForce 2MX AGP 32 Mb, Det. XP Windows 2000

Tom Nuydens
01-27-2002, 12:13 PM
Well I'll be damned. I'm the author of that demo, and it did work when I released it. No really, I'm positive http://www.opengl.org/discussion_boards/ubb/smile.gif

No idea what happened, but I suspect mightyMo hit the nail on the head.

-- Tom

[This message has been edited by Tom Nuydens (edited 01-27-2002).]

opla
01-28-2002, 01:16 AM
Same here, using a GeForce3

richardve
05-30-2002, 02:13 PM
It works with the 28.32 drivers http://www.opengl.org/discussion_boards/ubb/smile.gif

Only weird thing though is that you have to send the program WM_PAINT messages..
(ie. by moving another window on top of the OGL window)

(and I'm still using a GeForce3 Ti 200 - XP)

WhatEver
05-30-2002, 02:39 PM
It looked fine on my GeForce2 GTS. Hmmmm...it says driver version 2.8.3.2 but that doesn't match anyone elses driver version...*shrugs*