PDA

View Full Version : why would it be that i can't get shadow volumes and raster fonts to work simultaneous



wildeyedboyfromfreecloud
02-11-2002, 05:16 PM
well that was crude but i ran out of characters. so i can get my object class to cast shadow volumes but when i do i am unable to display 2d fonts. well actually i was trying to impliment shadow volumes in my main system. but i couldn't get them to work even though everything seemed air tight. so i started a new project. and the shadows worked just marveously. but i can't get fonts to work in the project that supports shadow volumes for no good reason beknownst to myself. and i can't get shadow volumes to work in my main project that does support fonts. maybe it is just a coincidense. but i figure maybe one of the buffers is getting intwined but i've tried everything. i believe my fonts change to the color of the depth mask. and i just confirmed that. please if you could give me some advice i'd apreciate it.

dorbie
02-11-2002, 05:23 PM
It sounds like you have state settings from one algorithm 'leaking' over into another state. For example, perhaps your fonts don't work because you still have stencil testing enabled when you enter the font code. Perhaps shadow volumes don't work because you still have alpha testing on when you draw the volumes. These are just a couple of suggestions, there are many possibilities.

wildeyedboyfromfreecloud
02-11-2002, 05:29 PM
yeah that is what i've been thinking. i will just keep looking. the bulk of the code i borrowed and assimilated into my system. i guess they were not encapsulated enough. thanks a lot i will keep looking. apreciate it -Michael-

wildeyedboyfromfreecloud
02-11-2002, 05:52 PM
i'm rather certain the total fault lies in my pixel format descriptor. it looks rather important i think i should take a time out to come to fully apreciate it. i've kinda glossed over it to this point. forgive my greeness.