PDA

View Full Version : Can someone can test my demo?



Arath
10-22-2002, 08:50 AM
You can download it here :

http://thechaosengine.free.fr

it weights 10 MB but it's worth it :-)

I only tested it on nvidia stuff, btw you need a 1 Ghz cpu, 256 meg and GF3-4 / ati radeon 9700 and openGL 1.4 driver is needed.

This demo includes two GDC2002 papers in action and more effects ...

Any advices are welcome,
Arath

Humus
10-22-2002, 10:01 AM
Works fine on Radeon 8500, except that it crashes at the end of the pool scene.
A suggestion though, 60Hz isn't cool, EnumDisplayModes() is your friend http://www.opengl.org/discussion_boards/ubb/smile.gif

Arath
10-22-2002, 10:24 AM
Yeah, I totaly forgot to use the EnumDisplayMode func, thanks, btw the demo isn't finished at the pool scene :-(( since I haven't got a ati, it will be hard to debug.

Arath

yakuza
10-22-2002, 06:08 PM
It errors out on my 8500, complaining of no vertex program support. Humus must have some yummy drivers. http://www.opengl.org/discussion_boards/ubb/smile.gif

Humus
10-22-2002, 09:26 PM
The 6193 has support for ARB_vertex_program. Fetch them at rage3d.com

Bruno
10-23-2002, 12:27 AM
It also complains about the no vertex programs support,but... i have the latest drivers, and it shows up on the space banana2 log file..

yakuza
10-23-2002, 05:32 AM
The 6193 has support for ARB_vertex_program. Fetch them at rage3d.com


I had wondered if those had support, or if you had some double-secret source of beta drivers. http://www.opengl.org/discussion_boards/ubb/biggrin.gif Thanks for the tip, Humus, I'll try those when I get home from work tonight.

yakuza
10-23-2002, 06:55 PM
Runs fine on my 8500 now that I downloaded the beta drivers Humus recommended. I didn't get the crash after the pool scene either, I was able to use the free mouse look at the end w/ the credits.

The hatching scene ran rather slow for me, but it could be my 1.1 ghz Athlon not being fast enough.

Nice demo, thanks for sharing. http://www.opengl.org/discussion_boards/ubb/smile.gif

Arath
10-24-2002, 03:56 AM
The hatching scene only uses 3d texture, vertex program and texture compression ... strange, I tought that the cube scene was the slowest ... btw thanks for you feed back, I'm happy that ati has released drivers for ati 8500, so you have been able to test my demo. Thanks again, you can watch to the vertex program if you want, there are in the vp subdirectory.

Arath

knackered
10-24-2002, 07:06 AM
Doesn't work on the geforce4 TI4600 with the 30.82 detonators.
Comes up with a "are you sure your card is 1.4 compatible?" message.

Asgard
10-24-2002, 07:09 AM
His demo uses the ARB_vertex_program extension which is only offered by release 40 drivers.

The demo runs fine on my GF4 Ti4200 on an Athlon 1 Ghz by the way. Also the hatching scene seems to run at full frame rate.

[This message has been edited by Asgard (edited 10-24-2002).]