PDA

View Full Version : problem with libjpeg under MS VC++6.0



sarisa
12-20-2003, 11:39 AM
Hi,

I guess it's not topic assigned with opengl much, but i think lot of you are using libjpeg. I've been using it with opengl, but under linux and now i gotta use microsoft visual c++ 6.0 on windows, i've compiled properly libjpeg, but when i try to build something (even when i link libjpeg.lib) it outputs me for example like that:

Linking...
cccc.obj : error LNK2001: unresolved external symbol "void __cdecl jpeg_destroy_decompress(struct jpeg_decompress_struct *)" (?jpeg_destroy_decompress@@YAXPAUjpeg_decompress_s truct@@@Z)
cccc.obj : error LNK2001: unresolved external symbol "int __cdecl jpeg_read_header(struct jpeg_decompress_struct *,unsigned char)" (?jpeg_read_header@@YAHPAUjpeg_decompress_struct@@ E@Z)
cccc.obj : error LNK2001: unresolved external symbol "void __cdecl jpeg_stdio_src(struct jpeg_decompress_struct *,struct _iobuf *)" (?jpeg_stdio_src@@YAXPAUjpeg_decompress_struct@@PA U_iobuf@@@Z)
cccc.obj : error LNK2001: unresolved external symbol "void __cdecl jpeg_CreateDecompress(struct jpeg_decompress_struct *,int,unsigned int)" (?jpeg_CreateDecompress@@YAXPAUjpeg_decompress_str uct@@HI@Z)
cccc.obj : error LNK2001: unresolved external symbol "struct jpeg_error_mgr * __cdecl jpeg_std_error(struct jpeg_error_mgr *)" (?jpeg_std_error@@YAPAUjpeg_error_mgr@@PAU1@@Z)

I ain't know what's wrong. I'm not familiarized well with VC++6.0 so i don't know what's wrong (so far i've been using gcc under linux), anything else is going OK, only this libjpeg's messing me.
I'd be very gratefull with any help!

Tom Nuydens
12-21-2003, 11:25 AM
This question is indeed not at all related to OpenGL. You may have more luck at, for instance, www.gamedev.net (http://www.gamedev.net) .

-- Tom