PDA

View Full Version : Wierd VAR Performance!



Sundy
07-29-2002, 02:34 PM
Hi,

For some reason when I allocate VAR in System Memory(priority = 0), I get more performance about (2.7 Million Tri/ Sec) than on AGP memory(priority = 0.5) I get only 2.2 Million Tri/Sec, But at the same time I get around 6 Million Tri/Sec when I allocate VAR in video memory(which was expected). Any Ideas?

2 Register Combiner Stages and enabled in all cases With Per-Pixel Lighting.

My config
AMD Athlon 700
AMD 751 Chipset
Geforce 256
512 MB RAM.

Is it because of my chipset? I hear NVIDIA turns off even AGP 2X on the AMD 751 Chipset. Is it true?

Thanks,
Sundar

Adrian
07-29-2002, 02:41 PM
You could try NVIDIAs VAR demo to see if you get the same kind of performance issues. That would tell you whether its your code or your hardware.

Sundy
07-29-2002, 02:57 PM
Originally posted by Adrian:
You could try NVIDIAs VAR demo to see if you get the same kind of performance issues. That would tell you whether its your code or your hardware.

NVIDIA's Var demo is very basic, I guess all it does is send the vertices and the normals This might be well under AGP 1X Limit. My scene is lit By 4 Lights, so I send the Vertices along with 4 Tangent space Vectors, Besides, I have enabled Register Combiners. and I send around 200,000 triangles every second. If something is wrong with my APP, then I should have the same problem when my var is allocated in Video Memory, But I get peak performance when I allocate my VAR in Video Memory.

Thanks,
Sundar

Adrian
07-29-2002, 03:29 PM
Send it to me and I'll benchmark it if you like? One of the systems I have here is comparable to yours. Its a P3 700 with a GF2.