PDA

View Full Version : Blank taskbar button after screensaver preview



tcobbs
02-12-2002, 07:54 PM
I have created an OpenGL screen saver, and everything seems to work fine, except that it leaves the infamous blank taskbar button around after previewing it from the Screen Saver control panel. Interestingly enough, the standard OpenGL screen savers that come with Windows 98SE do the same thing.

I don't get the problem when the screensavers run normaly, only when being previewed. I'm running Windows 98 Second Edition, with an nVidia GeForce 3 and the 23.11 Stereo drivers. Does anyone else have this problem? Despite the fact that the standard OpenGL screen savers exhibit this problem, is there anything I can do to prevent mine from doing so?

--Travis Cobbs

Gorg
02-12-2002, 08:20 PM
Don't worry about this. It is not your problem.

I am too lazy to find MS bug report on this, but you can find it on MSDN if you really feel like looking for it.

tcobbs
02-13-2002, 05:26 PM
Originally posted by Gorg:
Don't worry about this. It is not your problem.

I am too lazy to find MS bug report on this, but you can find it on MSDN if you really feel like looking for it.

I'd pretty much come to the conclusion that it wasn't my fault. However, if there is anything I can do to fix it, I would like to do so. Are you saying that there is no fix? (I looked for any reference on msdn.microsoft.com and couldn't find any.)

--Travis Cobbs

Gorg
02-13-2002, 06:38 PM
Sorry. I do not know any workaround.

tcobbs
02-13-2002, 08:23 PM
Thanks. I managed to solve the problem. I had forgotten that my screensaver had two different ways to exit (either through an event to my fullscreen window, or an event to my OpenGL subwindow). I had monkeyed around with the exit code in the OpenGL subwindow, but not the fullscreen window. I have now unified that code.

At this point I'm not real sure which of my modifications fixed the problem, but the order that things get shut down in at the end seems to be important.

--Travis Cobbs