PDA

View Full Version : GeForce 4200Go and 3d textures



PhilY
05-06-2003, 11:01 AM
Hi,

My boss just bought a Dell laptop with GF4200Go with 128mb ram. When I run my program, the driver does expose the entension and I am able to use it. However, it's running VERY slowly - obviously it's running in software. Does anyone know if this card is going to do 3D textures in hardware anytime soon? ever?

I read the product overview PDF at nVidia's developer's website and it claims it does 3D textures - and it does, just not in hardware which is pretty much worthless.

Also, I know this prolly has been beaten to death but is there any way to find out if certain extensions are supported in software at run-time?

Any input will be appreciated.

jra101
05-06-2003, 11:11 AM
That card should definitely support 3D textures in hardware. Does GL_EXT_texture3D show up in the extensions string? How are you testing the speed?

davepermen
05-06-2003, 12:07 PM
isn't a go, just like the mx, a "wrapped" gf2?

Won
05-06-2003, 12:42 PM
How big is your 3D texture? How slow is slow? What version are the drivers? I have the same laptop video.

Dave -- no, the 4200Go is programmable like the Geforce4 non-MX, but with less memory bandwidth.

-Won

jra101
05-06-2003, 12:45 PM
The GF4 4200 Go is the same hardware as the desktop GF4 4200.

Lars
05-06-2003, 01:35 PM
Hi

What resolution are your 3d textures and which format?
Did they run on GeForce4/3 Level Hardware before?

The 4200 only support 512x512x512 3D textures. And large 3d textures can be to much even for 128 MB espacially if the notebook runs with full wuxga resolution.

Lars

davepermen
05-07-2003, 01:07 AM
Originally posted by Won:
Dave -- no, the 4200Go is programmable like the Geforce4 non-MX, but with less memory bandwidth.

good to know!! thanks

PhilY
05-07-2003, 12:47 PM
Thanks everyone for your replies.

Here are some of answers to your questions:
- GL_EXT_texture3D does show up in the extension string
- Texture size is only 8 MB, RGBA8 format, dimensions are 64X64X64
- Resolution of 1600X1200 or something like that
- The same code runs fine (fast) on GeForce4 4200 64MB, Oxygen GVX1 32MB, and Radeon 7200 32MB

I'm just eyeballing speed but it runs about 50 times slower on the Geforce4200Go than on a Radeon7200 with 32 megs of RAM http://www.opengl.org/discussion_boards/ubb/smile.gif So I'm quite sure that it's doing it in software.

The driver on it was released sometime in late 2002. I told him to get the latest driver from Dell and try again. I'll let you all know if that solves the problems. If that doesn't work, I'm gonna try to install the latest driver from nVidia using that .inf file tricked mentioned earlier on this board.

Oh, another thing: there's no way for Geforce4 Go 440 or 420 to do 3d textures in HW, correct? I know it's just GF2 in the core but just making sure.

jra101
05-07-2003, 12:52 PM
No, you won't be able to do 3D textures in hardware on the 440 or 420 models.