PDA

View Full Version : Help!Problem about GL_STEREO ?



ruochenlingxi
11-01-2004, 02:42 AM
I have an Nvidia quadro FX 1100 card and Nvidia GeForce5950 card, Installed 61.77 graphics driver (61.77_win2kxp_english.exe) and the 61.77 Stereo driver (61.77_3dstereo.exe)
Enabled stereo in the stereo properties.(I can't find and enable the option of the page-flipping)
The medical application and the test application work very good in 3D .
I tried my OpenGL application where i set glutInitDisplayMode(GLUT_RGBA | GLUT_DOUBLE | GLUT_DEPTH | GLUT_STEREO).But it didn't work and gave the error message GLUT:Fatal Error.....:pixel format with necessary capabilities not found.
How can I deal with this?Please give me some advices.Thank you!

Klaus
11-01-2004, 05:11 PM
GLUT_STEREO refers to quadbuffer stereo which is only supported on Quadro cards. The NVIDIA stereo driver only supports consumer cards and works transparently with any fullscreen OpenGL or DirectX application without explicit stereo support.

So GLUT_STEREO should work with your Quadro card and will not work with your 5950. That's why you pay extra bucks for Quadro cards ...

- Klaus

ruochenlingxi
11-01-2004, 06:00 PM
I have the same problem in the Quadro card .Do you mean that I can use the quad-buffer in the fullscreen mode without set GL_STEREO?Ihave done some tests,but have no effort.Can you give me some advices?

Relic
11-02-2004, 03:08 AM
The Quadro board will support the pixelformat with GL_STEREO just fine if you enable the stereo pixelformat export in the display control panel OpenGL Advanced tab.
It is not restricted to fullscreen, it works per window.
There is no need to install the consumer stereo driver for this case.