PDA

View Full Version : Help! GL_TEXTURE_GEN_S wont stop..



fritzlang
02-11-2002, 02:26 PM
Hello.
Im doing this but OpenGL still
genererate coordinates..?

//glDisable(GL_TEXTURE_GEN_S);
//glDisable(GL_TEXTURE_GEN_T);
//glDisable(GL_TEXTURE_GEN_R);
//glDisable(GL_TEXTURE_GEN_Q);

cheers

Zeno
02-11-2002, 03:06 PM
Originally posted by fritzlang:
Hello.
Im doing this but OpenGL still
genererate coordinates..?

//glDisable(GL_TEXTURE_GEN_S);
//glDisable(GL_TEXTURE_GEN_T);
//glDisable(GL_TEXTURE_GEN_R);
//glDisable(GL_TEXTURE_GEN_Q);

cheers

Must....not....make....obvious....joke....

-- Zeno

Gorg
02-11-2002, 03:31 PM
Originally posted by Zeno:
Must....not....make....obvious....joke....

-- Zeno

LOL. I had the same idea http://www.opengl.org/discussion_boards/ubb/smile.gif

SirKnight
02-11-2002, 04:48 PM
Heh, ok i wont say anything. http://www.opengl.org/discussion_boards/ubb/wink.gif How about deleting the glEnable code AND the glDisable code that has to do with GL_TEXTURE_GEN_<X> from your code. Why do you wonder why opengl still generates the coords after you comment out the disable lines anyway? It uh...just doesnt make sence. http://www.opengl.org/discussion_boards/ubb/smile.gif

-SirKnight

fritzlang
02-11-2002, 05:32 PM
Thanks, but really.. 4*// was just to
make things a bit interesting..

Seriously, I spent a fair amount of time
making sure it is not enabled, and anyway, whatever happened before, this should still
just stop it:!?

glDisable(GL_TEXTURE_GEN_S);
glDisable(GL_TEXTURE_GEN_T);
glDisable(GL_TEXTURE_GEN_R);
glDisable(GL_TEXTURE_GEN_Q);

..drawing a textured quad here
still generates auto-texcoords..

Never heard of any other way to
turn texgen off, other than
glDisable(..).

cheers

Zeno
02-11-2002, 06:28 PM
Yes, your glDisables should stop the texture coordinate generation. You are disabling for the same texture unit that you enabled for, right? i.e. make sure your last glActiveTextureARB() is correct....

-- Zeno