PDA

View Full Version : seams in cube map...



147-2
07-07-2003, 01:21 PM
It seems I have seams in the corners of my cube map. I am using a G-Farce FX 5200. I have tried using bmp files for the cube map faces, as well as using the normalization cube map generator offered by nVidia. Both attempts have created seams in the cube. On both attempts, to enter the textures I used gluBuild2DMipmaps() since glTexImage2D() doesn't seem to work at all. I doubt gluBuild2DMipmaps is at fault...

Might it just be my video card?

sqrt[-1]
07-07-2003, 02:13 PM
Ensure you are using GL_CLAMP_TO_EDGE instead of GL_CLAMP

Xmas
07-07-2003, 02:15 PM
What texture clamp mode do you use?

147-2
07-07-2003, 02:51 PM
BAH! I knew it... I knew I forgot something.


Thank you very much for the info. I feel dumb now. :P

Ostsol
07-07-2003, 02:56 PM
Interesting. . . Didn't NVidia drivers used to default GL_CLAMP to GL_CLAMP_TO_EDGE in order to solve a seaming issue in games where some developers wrongly used GL_CLAMP? I seem to remember reading about that a while back. . . Must be an application specific thing, now. . .

[This message has been edited by Ostsol (edited 07-07-2003).]

Nutty
07-07-2003, 11:42 PM
They do on all Geforce hardware, unless you have "OpenGL conformant GL_CLAMP behaviour" turned on in your opengl driver settings.

vincoof
07-08-2003, 12:12 AM
Originally posted by 147-2:
On both attempts, to enter the textures I used gluBuild2DMipmaps() since glTexImage2D() doesn't seem to work at all.
I bet glTexImage2D does work, but you have to disable mipmapping if you only define the first level of your texture object. Since gluBuild2DMipmaps does fill all mipmap levels, that explains why it "seems to work" whereas glTexImage2D "doesn't seem to work".

Nutty
07-08-2003, 12:31 AM
Or perhaps his texture dimensions aren't power of 2, and thus gluBuild2DMipmaps() auto scales, which makes it work.

147-2
07-08-2003, 01:44 PM
The textures are powers of 2, its just that I have mipmapping on. That's ok I suppose, it's not causing any problems.


Oh, and those cubes don't have seams in them any more. Thank you very much for your support.

[This message has been edited by 147-2 (edited 07-08-2003).]