PDA

View Full Version : ATI driver bug ?



McBain
12-30-2002, 08:03 AM
I have found (what i think) is a possible bug in the ATI drivers in ARG_vertex_program. The bug occurs when calling glVertexAttrib*ARB(x, *) in a display list, and referencing to generic attribute x in the vertex program.

I wrote a simple test program for the bug.

c code can be found @ http://www.cs.kuleuven.ac.be/~ares/atibug/atibug.cpp

a vc6 workspace can be found at http://www.cs.kuleuven.ac.be/~ares/atibug/vc6.zip

a exe file can be found at http://www.cs.kuleuven.ac.be/~ares/atibug/bin.zip

on my system the program crashes, or displays nothing (and then crashes after minimizing the window)
I have a RADEON 9700 Pro, and the problem occurs with all catalyst drivers 2.5 - 3.0, windows XP

normally, it should just display a purplish quad.

i suspect the program will run fine on NVIDIA hardware.

i would appreciate if other people could try this program and report findings here. If you run the program, dont leave any documents open (on my system open files get corrupted when crashing)

I would very much appreciate if someone knows a workaround or a solution for this bug.

best regards,
McBain

McBain
12-30-2002, 08:45 AM
someone on irc was so kind to test this program on a NV GeForce4 4600
As i expeced, it works just fine.

nolife
12-30-2002, 01:54 PM
Hi;)
Ye Geforce 4 TI 4600, running on an Athlon 2000XP and WinXP.
Using latest 41.09 detonator.
Doesn't crash here.

good luck in finding the bug

McBain
12-30-2002, 02:10 PM
I got confirmation from another 9700 user on irc; the program crashes (and it shouldnt).

NitroGL
12-30-2002, 03:39 PM
It doesn't crash here (on my 9700), but the window is blank.

McBain
12-31-2002, 12:11 AM
Nitro: it seems to crash on a window redraw, try to minimize your window, and see if it crashes then.

best regards;
McBain

McBain
01-01-2003, 11:39 AM
i've got confirmation from ATI devrel, it is a driver bug.

best regards
Ares Lagae