PDA

View Full Version : FPS loss with two monitors on a 7800 GTX



dimensionX
07-15-2005, 08:18 AM
Systems Specs:-
---------------
Intel Xeon 3.4GHz
1GB RAM
GeforceFX 7800 GTX (two DVI outputs)

Configuration 1:-
-----------------
Only one projector connected to the 7800 GTX.
No extended desktop.
Projector1 running at 1024x768 resolution/60Hz.

In this configuration, I have an application that runs at 60 FPS.

Configuration 2:-
-----------------
Two projectors connected to two graphics card outputs.
Extended Desktop.
Both Projectors running at 1024x768 resolution/60Hz.

In this configuration my applications FPS falls to 18 FPS.

I tried disabling Vertical Sync, Antialiasing, Anisotropic filtering etc... to see if it inproves framerate. I even tried to reduce the resolution of the projectors to 800x600/60Hz. Nothing seems to improve the framerate from 18FPS. I need atleast 30FPS.

Does anyone has any idea what is causing the a drop in FPS ?

Aeluned
07-15-2005, 09:02 AM
I believe this problem has been around for a while.
I've had the same problems since 5600.

I have given up trying to use extended desktops while performance is critical due to the FPS drop you mentioned.

Jan
07-15-2005, 02:37 PM
Interessting, seems to be an nVidia-only issue. With my Radeon 9700 Mobility i use an extended desktop (Laptop LCD + Monitor) and everything runs just fine. In windowed mode i can even move the running OpenGL-Window from one desktop to the other.

Jan.

dimensionX
07-15-2005, 02:41 PM
I figured the problem. Just have to set the "Horizontal Span" mode in the nView settings.

Yes, I get back my FPS. So I am happy!