PDA

View Full Version : API for vs1.0 / ps1.0



k_szczech
06-27-2006, 03:41 PM
My game uses GLSL shaders. I've replaced two of them with assembly shaders (actually these are my two first assembly shaders ever ;) ).

Why? Because I want my shaders (these two actually) to run on GeForce 3 / 4 and Radeon 8500 / 9000.

I have GeForce 7800 and I'm using ARB_fragment_program / ARB_vertex_program API to handle my shaders.

I've checked delphi3d.net - On Radeon 8500 I have GL_ATI_fragment_shader, but I can't find anything in the GeForce 4Ti extensions list that would look like fragment shaders.

I did some search with google but to no avail.

Any help/links will be appreciated.

moebi
06-27-2006, 05:55 PM
nVidia supports fragment shaders since GeForce FX series. On GeForce3 cards you have to mess around with register combiners and so called "texture shaders", sad but true... one reason why I replaced my GF3 Ti200 for a GF6800GT ;)

k_szczech
06-27-2006, 06:41 PM
you have to mess around with register combiners and so called "texture shaders"That's what I suspected. The only way to make per-pixel distortion I've found for GF3/GF4 was using these texture shaders.

sad but trueAmen to that...