PDA

View Full Version : What version????????



slipknotclown
01-02-2002, 01:35 AM
Ok I want to buy a book to teach me opengl, but the main one which i forgot what its called uses version 1.1, i see things about 1.3 and 2.0 on this site and so is there going to be the old problem about using old technology? or doesnt it matter? Please tell me a book to get which preferbly uses latest verion. ps I'm from uk

James

Bob
01-02-2002, 03:58 AM
The book you refer to is probably the Red Book, aka the OpenGL progamming guide and it covers version 1.2. A version for 1.3 is on the way (I think one of the authors of that book said he's working on it).

But if you want to buy the book to learn OpenGL, then you can get very far only with OpenGL 1.1. So that's no problem. And for OpenGL 2.0, that spec. is not even done yet, and a book is probably not out within at least a year after OpenGL 2.0 is realeased.

If you need a book right now, I strongly suggest you go for the programming guide that covers version 1.2.