PDA

View Full Version : 1.4 Headers?



kaysoft
10-06-2002, 12:17 PM
I am quite confused here, as searching the net trying to find the latest opengl headers, i saw the MS is supporting opengl 1.1 only, is that true? If it is, how can I get support for GL 1.4 and find the headers for it?

nomad82
10-06-2002, 10:42 PM
they're treated as "extensions"... http://www.opengl.org/discussion_boards/ubb/wink.gif.

kaysoft
10-07-2002, 12:39 AM
so the glext provided at NVIDIA OpenGL SDK is actually the 1.4 extensions? Please, someone make this clear to me http://www.opengl.org/discussion_boards/ubb/smile.gif

MichaelK
10-07-2002, 01:30 AM
The statement "MS is supporting opengl 1.1 only" IMHO means that if you dont have hw accel (such as nvidia detonators), you will have only software implementation of OpenGL in version 1.1.

kaysoft
10-07-2002, 02:26 AM
I do have NVIDIA latest detonators, i have the GF2MX400 card, so I do have hw acceleration. All I want to know is if the opengl32.dll is updated with the drivers, is it?

Bob
10-07-2002, 04:53 AM
opengl32.dll is not updated when you update your driver.

mikael_aronsson
10-07-2002, 05:33 AM
Hi !

When you update your drivers you get 1.4 support (if your driver supports it) and you will be able to use all 1.4 features enabled by your driver and hardware, this has nothing to do with opengl32.dll, this satys the same.

You do need to get new header files to use the extensions and so on.

What it all means is that MS software only OpenGL support is 1.1 only, no 1.4 features at all, this is why you download updated drivers from your manufacturer to get your card up and running.

I hope that clears it up a bit.

Mikael

kaysoft
10-07-2002, 06:05 AM
Ohh, i see now. So I do not update the opengl32.dll or the gl.h and glu.h, I just use the extensions in the glext.h? right?