PDA

View Full Version : Only 60 fps



Alcionei Estevam Jr
11-20-2002, 02:30 PM
Hi all,

When I try display a simple triangle in my display, I have only 60 fps. Why this limitation?

yakuza
11-20-2002, 02:44 PM
Vsync. Your graphics card is limiting the draw rate to the vertical refresh rate of your display, which is usually 60 hertz. Look for a "Disable vsync" option in your graphics settings.

Hope that helps.

Alcionei Estevam Jr
11-23-2002, 12:36 PM
Thanks Yakusa,

Now I would like to saw how to increase the draw rate by opengl code. This is possible?



Originally posted by yakuza:
Vsync. Your graphics card is limiting the draw rate to the vertical refresh rate of your display, which is usually 60 hertz. Look for a "Disable vsync" option in your graphics settings.

Hope that helps.

slur
11-25-2002, 11:55 PM
I'm developing with OpenGL / SDL on Mac OS X. To enable vsync in my program I used this code:

CGLContextObj ctx = CGLGetCurrentContext();
const long interval = 1;

CGLSetParameter(ctx, kCGLCPSwapInterval, &interval);


And to disable vsync I set interval = 0.

alcionei
11-28-2002, 03:31 AM
Very Tanks Slur



Originally posted by slur:
I'm developing with OpenGL / SDL on Mac OS X. To enable vsync in my program I used this code:

CGLContextObj ctx = CGLGetCurrentContext();
const long interval = 1;

CGLSetParameter(ctx, kCGLCPSwapInterval, &interval);


And to disable vsync I set interval = 0.