PDA

View Full Version : glutGameMode under WinNT



xroads42
01-12-2001, 04:33 AM
Hi!

I got a porblem with glutGameMode. Under windows98 i get about 600fps ( just a falling Cube). But under WinNT its allways just 60fps even if i disable textures.
Both Systems are a PIII 450Mhz.

My glutGameMode code is:

glutGameModeString("640x480:16@60");
glutEnterGameMode();

Thx so far,

XRoads42

Bob
01-12-2001, 05:07 AM
60 fps, huh? Sounds like vertical sync is enabled. Either disable it, or live with it. I prefer vsync on, because it prevents your application from running at ridicoulus framerates.

Try set the monitors HZ to 75 or so in glutGameModeString and see if it goes up to 75 fps. If not, something else might be wrong.

[This message has been edited by Bob (edited 01-12-2001).]

xroads42
01-12-2001, 06:40 AM
Thx, how do i enable vsync in win98?

j
01-12-2001, 06:49 AM
It's usually in the display settings.

j

Moz
01-12-2001, 09:46 AM
If you want to enable vsync in your program, you can try using WGL_EXT_swap_control. http://oss.sgi.com/projects/ogl-sample/registry/EXT/wgl_swap_control.txt