PDA

View Full Version : problem



mohit04
06-22-2003, 01:19 AM
please help me in setting up glut for my win environment....i m using dev-c++ environment..and a simple rpogram doesnt work...please help...

mikael_aronsson
06-22-2003, 09:13 AM
Hi !

Could you give some more details maybe "doesn't work" is not a very useful description of a problem, do you get compilation errors ? linking errors ? runtime erros ? what ?

Mikael

Sourpotato
06-23-2003, 06:53 PM
put the glut.h in project and try to link the glut.dll and glut.lib

nexusone
06-24-2003, 07:57 AM
Since we are not mind readers and there are lot's of diffrent compilers and versions.
Please include the compiler name and version.
Also what the error is, word for word what the compiler tells you.

I think glut is shipped with all version of DEV-C++, I use it and did not have to do anything special to get it to work.

Common problems are:
Not linking the glut library in the project settings.

Also can go to my website which show's you how to setup DEV-C++ for compiling openGL programs.
www.angelfire.com/linux/nexusone/ (http://www.angelfire.com/linux/nexusone/)



Originally posted by mohit04:
please help me in setting up glut for my win environment....i m using dev-c++ environment..and a simple rpogram doesnt work...please help...

06-24-2003, 12:18 PM
Have you already downloaded glut library files? If not please search for these files and downlaod to your system. Then do the following:
1. Copy all the ".h" files to your visual studio win32 "include/GL" folder.
2. Copy all the ".lib" files to the Microsoft visual directory.
3. Finally copy all the ".dll" files to the win32 folder.
Good-luck.