PDA

View Full Version : OpenGL rendering stopped working



Bob H
08-27-2006, 06:42 AM
I have been successfully using OpenGL for a single Windows dibsection.

When I create a second dibsection associated with a popup window, close that window and destroy the second dibsection (which had successful OpenGL rendering by the way), OpenGL rendering for the first dibsection no longer works.

I tried saving the DC and context before creating the second dibsection and then setting wglMakeCurrent( hOldDC, hOldRC ) after the second dibsection was destroyed. That didn't help.

I tried repeating the entire process for creating an OpenGL view for the first dibsection. That didn't help.

I can provide all the code for reassigning the OpenGL view for the first dibsection if that is helpful.

What am I doing wrong?

08-29-2006, 11:34 AM
http://www.opengl.org/discussion_boards/ubb/ultimatebb.php?ubb=get_topic;f=9;t=000730

You might consider deleting this thread or the other, as multithreading is generally frowned upon in the context of single core topics. The windows forum seems to be more appropriate.

I regret that I've no advice for you, except to suggest that you post some code that demonstrates the problem, along with your system specs and driver verison.

hth

Bob H
08-30-2006, 05:45 AM
I am not able to delete it. It says that only administrators or moderators can delete the topic.