PDA

View Full Version : OpenGL and Windows 2000



armin
05-21-2001, 10:44 PM
Hi,

I installed OpenGL under windows NT successfully and then I tried to do the same under windows 2000 - however this did not work.

Does anybody know what might be the problem ?

Thanks !

Bob
05-21-2001, 10:55 PM
Did you use the same drivers for Win2k as for WinNT, or did you use drivers specifically designed for Win2k?

armin
05-21-2001, 11:23 PM
Hi Bob,

thanks for your answer.

I used opengl32.dll and glu32.dll which came with Win2k.
However I also used glut32.dll which came with the book I bought about OpenGL and which was designed for Win9x or WinNT.
Maybe this is the problem - I checked the GLUT-homepage if there are any information about this issue - however I did not find anything.

Bob
05-22-2001, 12:20 AM
OK, there should be no problems with glut32.dll. This file works on all Win32 platforms. And since opengl32.dll and glu32.dll is shipped with Windows, I assume there's nothing wrong with these files.

What kind of error do you get. Is it a runtime error, or a compiletime error? Post any errorcode/message you get.

armin
05-22-2001, 12:37 AM
When I try to run some sample programs which shipped with the book
I get the following error message:

The application failed to initialize properly (0xc0000142).

Under WinNT I do not get this message and everything works perfectly fine.

Jigzy
05-27-2001, 09:56 PM
Have you tried to download and use a new win2000 driver for your graphics card.

The first win2000 driver for my card did not support openGL, but the next version did.

I dont know which card you have, but the driver should include openGL support by now.

armin
05-28-2001, 12:27 AM
I have a NVIDIA GeForce2 MX 400 64MB graphis card and I downloaded a new driver from the companies web page (nvoglnt.dll). I put it in Winnt/system32.
However it did not work.

I have really no idea what is the problem.

1.) Bob said there should be no problem with the Glut32.dll library
2.) I installed the graphic card driver

what else can I do ?

ET3D
05-28-2001, 01:37 AM
While Bob said that there shouldn't be a problem with Glut, I suggest that you download and install the latest version anyway.

armin
05-28-2001, 03:53 AM
I downloaded glut-3.7.3 --- still no succes :-(

The OpenGL-Superbible includes some demos and the samples of each chapter
While I can run the demos I am not able to run the sample programs.

sedatmav
05-28-2001, 09:07 PM
it is a bit silly but wanna ask what is the exact way install the glsetup under win 2k ?what should do?please am looking forward to your help

T2k
05-28-2001, 11:43 PM
try to recompile the code if it isnt yours ...

armin
05-29-2001, 12:09 AM
I recompiled the code and get no error messages.

... seems that I have to install winNT in order to run the sample programs.

Deiussum
05-29-2001, 05:32 AM
You said you just placed nvoglnt.dll in your system directory? Maybe you should actually try going through the process of installing the drivers rather than copying files around yourself. I'd suggest getting the Detonator drivers for Win2k from nVidia and following the instructions on how to install them.

armin
05-29-2001, 07:26 AM
Actually I installed a new driver.

I just installed now the driver you recommended:
NVIDIA Detonator 3 version 11.01 for win2k.

It still does not work....:mad

Deiussum
05-29-2001, 10:28 AM
Hmmmm.... weird. Are you using an official release of Win2k? I use Win2k both at work and at home and have never had problems with OpenGL apps.

armin
05-29-2001, 11:38 AM
I am using an official version of win2k.

I stress once more - on winNT everything works fine.

http://www.opengl.org/discussion_boards/ubb/mad.gif, http://www.opengl.org/discussion_boards/ubb/mad.gif

Deiussum
05-30-2001, 05:17 AM
Is it just the demos you are having problems with or all OpenGL apps? (i.e. Do you have problems with the OpenGL screensavers that come with win2k.)

It's possible those demos are doing something else not related to OpenGL that Win2k isn't liking.

Rizo
05-30-2001, 11:16 AM
Hey Armin,

Careful there. Apps working on WinNT are not guranteed to work on Win2k.

Here, try this software.
http://www.nvidia.com/Marketing/develope...igidbody105.zip (http://www.nvidia.com/Marketing/developer/devrel.nsf/045cfdb95e306a4d882568170059fa93/c0f591e538dbb865882568fd000d1f20/$FILE/rigidbody105.zip)

See if you can get it to load. I've tested it on quite a few machine (even with WinNT and a none Geforce card...I was getting 0.6 FPS at 100x100 screen size).

Now, if all runs well, then the problem is with you application. It is perhaps doing something really weird. I once wrote a code that was working well on Win98SE but would crash on WinNT (I know Win98 is much different, but still). The problem was that I wasn't allocating enough memory for my string.

So check your code again. Make sure you don't have dangling pointers (reason why you get that error).

Reza

armin
05-30-2001, 11:33 PM
Hey Reza,

thanks very much for your help .

I tried to run the program you suggested , but I get the same error as for the sample programs. http://www.opengl.org/discussion_boards/ubb/frown.gif

Deiussum checked one sample program of mine on his system and everything worked fine http://www.opengl.org/discussion_boards/ubb/smile.gif

So obviously there must be a problem in my configuration - maybe it is a problem which does not have anything to do with OpenGL

armin
05-31-2001, 03:19 AM
apropos OpenGL screensaver -

they do not work either and I get the same error message as for the sample programs.

How can I make the OpenGL screensavers work ?

Deiussum
05-31-2001, 05:00 AM
I sent you my opengl32.dll and glu32.dll. Try replacing yours with these and see if that helps anything. (Maybe yours were corrupted somehow.) If that doesn't help, the only other thing I can think of trying is to reinstall the detonator drivers again.

jbraz
06-21-2002, 04:27 PM
Dear Deiussum

I'm having the exact same problem (0xc0000124) as Arnim with an Asus V7700/Pure/64MB (NVidia GeForce II GTS I think) under W2k.

I run all my OpenGL programs in a laptop with Wme, I run them even at work with W2k ... but not home ... at home only 0cx0000124 error!

I tried very simples programs only with OpenGL (their all Visual C++ embeded), with no glu, no glut no nothing ... and nothing but: 0cx0000124 error.

Can you send me your opengl32.dll driver for W2k