PDA

View Full Version : undeclared identifier errors



12-04-2000, 10:59 AM
I am currently having problems with opengl code in my game. when I try to use opengl fuctions and code, I get undeclared identifier errors. I included the gl.h, glu.h, opengl32.lib, and glu32.lib files in my project, and under my projects settings link tab, I typed in opengl32.lib and glu32.lib. I also included the header files. After all this, I still get undeclared identifier errors. what am I doing wrong? Someone please help me. I want to get on with developement of my game using opengl. my developement tool is microsoft visual c++ 6.0

MikeC
12-04-2000, 11:09 AM
Probably need to #include "windows.h" before you #include "gl.h". If you're using GLUT then just #include "glut.h" instead; it'll take care of everything else you need.

We REALLY need a FAQ pointer on this forum... http://www.opengl.org/discussion_boards/ubb/frown.gif

12-04-2000, 12:19 PM
these are the errors that i am receiving when compiling my source code.

Compiling...
Pong.cpp
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(255) : error C2065: 'glClear' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(255) : error C2065: 'GL_COLOR_BUFFER_BIT' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(256) : error C2065: 'glColor3f' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(257) : error C2065: 'glRectf' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(258) : error C2065: 'glFlush' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(259) : error C2065: 'glClearColor' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(260) : error C2065: 'GLfloat' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(260) : error C2146: syntax error : missing ';' before identifier 'x'
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(260) : error C2065: 'x' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(260) : warning C4244: '=' : conversion from 'const float' to 'int', possible loss of data
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(261) : error C2146: syntax error : missing ';' before identifier 'y'
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(261) : error C2065: 'y' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(261) : warning C4244: '=' : conversion from 'const float' to 'int', possible loss of data
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(262) : error C2146: syntax error : missing ';' before identifier 'rsize'
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(262) : error C2065: 'rsize' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(263) : error C2146: syntax error : missing ';' before identifier 'xvelocity'
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(263) : error C2065: 'xvelocity' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(263) : warning C4244: '=' : conversion from 'const float' to 'int', possible loss of data
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(264) : error C2146: syntax error : missing ';' before identifier 'yvelocity'
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(264) : error C2065: 'yvelocity' : undeclared identifier
C:\My Documents\Edem\Edem's Software\Edem Workspace\Software\Pong\Pong.cpp(264) : warning C4244: '=' : conversion from 'const float' to 'int', possible loss of data
Error executing cl.exe.

Pong.obj - 17 error(s), 4 warning(s)

MikeC
12-04-2000, 12:24 PM
Looks like something screwy with the #includes, plus a few typos. If you mail me the whole file I'll see if I can help. (Might not be until tomorrow though.)