PDA

View Full Version : Done but Un-finished!!!



o9i8
02-08-2002, 02:34 PM
I have just finnished all the primary function on my 3d Modeler source code, It draws in 3D no problem, Ah but It wont remember lines they pop out as soon as a new click is issued, So you get to draw one line then apon drawing the next the first vanishes
any Idea on how to fix this.......Thanks In Advance
regular filling up of variables
glBegin(GL_LINES);
glVertex3f(xb,yb,zb);
glVertex3f(xf,yf,zf);
glEnd();
glutSwapBuffers();
Whats making it vanish lack of numbered array ...


[This message has been edited by o9i8 (edited 02-10-2002).]

nexusone
02-08-2002, 04:14 PM
You would need to post the code in order for us to see what's going on.

How you are storing the vertex's and your drawing routine.


Originally posted by o9i8:

I have just finnished all the primary function on my 3d Modeler source code, It draws in 3D no problem, Ah but It wont remember lines they pop out as soon as a new click is issued, So you get to draw one line then apon drawing the next the first vanishes
any Idea on how to fix this.......Thanks In Advance

Leyder Dylan
02-10-2002, 10:08 AM
I think that you must swap the buffers after the "glEnd()"

With your program, you swap the buffer before telling to OpenGL that you've finished to draw your polys.

o9i8
02-10-2002, 07:20 PM
Leyder Dylan
good call I fixed it ya I wish it was something simple but well they say there no way to do animation with out array's so here I go write some Big fluky array. mmmmmmmmmmmmmmmmmmmm. I guess I will need pointers

[This message has been edited by o9i8 (edited 02-18-2002).]